• Welcome to the Land Rover UK Forums

    You are currently viewing the site as a guest and some content may not be available to you.

    Registration is quick and easy and will give you full access to the site and allow you to ask questions or make comments and join in on the conversation. If you would like to register then please Register Now

Fitted New Indicator Stalk/Switch

MIKESLANDY

Offroader
Hello all, fitted the above to my 89 90 tonight and has solved a lot of problems like unable to dim, indicators only worked on full beam etc. Now its all sorted with the new stalk/switch except I cant flash(courtesy lights), the function on the new stalk is there but nothing happens, was working on the faulty one I replaced. Any ideas?
Thanks
Mike
 
Another strange thing I have noticed is when I indicate the trailer light flashes on the dash not the arrow one. This trailer light used only flash with the arrow light if I had something plugged in.
Mike
 
The trailer light works on voltage drop I think so you may have a short or earth fault. As to 'Flashing', when I fitted mine there was a couple of little mini bullet connectors on the unit, while pushing in the wiring etc and refitting, one of these came off and gave me the same problem. I tightened it up with a pair of pliers and thankfully it all works.

Nige
 
Thanks for the reply Nige, the bullet connector was very tight when installing. Will have a wiggle around with the wires to see if anything changes.
Cheers
Mike
 
Back
Top Bottom