• Welcome to the Land Rover UK Forums

    You are currently viewing the site as a guest and some content may not be available to you.

    Registration is quick and easy and will give you full access to the site and allow you to ask questions or make comments and join in on the conversation. If you would like to register then please Register Now

Ignition problems


Big Landy Fan
Got round to starting the truck today (for the first time), It turns over atright but there is no spark coming from the coil. I know the coil is not a fault because i swaped it with a working coil and still no spark. :(

Does anyone have any ideas?:confused:

Help is appreciated.

First thing, make sure you have a feed to the coil, then check the points are opening and closing fully. Check the wires are connected correctly at the points. If you have Lucas points with the little nut, make sure both wires are below the plastic insulator.

Thanks For your quick reply.
We have 9 volts feed at the coil but 12 from the battery:confused:
We havebt checked the distributer yet, because we couldn't even get a spark from the ht lead coming from the coil?
9v at the coil input means you have a Ballast Resistor fitted. You won't get a spark until the points open and break the circuit.
Take the wire from the coil to the points off, you should have 9v with ignition on, touch the wire to the connection and the voltage will go to 0 or 1v if the points are closed or the wire is earthed. If it stays at 9v, the points are open.

Tried to get a spark again today, but no joy:(

I cant get a spark form either, plug to earth or h/t lead to earth. I have changed the truck form pos earth to neg earth. We never started it prior to polarity change.

There is just over 9volts at the l/t coil terminals.

Points seem to work OK, opening and closing the negative circit.

As TEMPL4R previosly suggested a ballast resistor was fitted, problem is I cant find it nor does the hanyes book of words mention it? :confused:

I think i am missing something blatantly obvoius.

Any ideas would be appreciated

Hello there.If you have low voltage at the switch side of the coil, you can " hot wire " the coil thus giving you direct battery voltage . Disconnect the coil feed wire and connect direct to the battery positive terminal.If you still do not get a spark,you will have to go back to basics .Start by cleaning/setting the points. Regards Billy :)
If you changed it from Positive earth, did you change the coil terminals as well?

You need to provide a feed to the primary and secondary coil windings. If it says + and - on the coil, make sure the - is to the points. (Some say IGN and CB)

From Wickypedia " For an ignition coil, one end of windings of both the primary and secondary are connected together. This common point is connected to the battery (usually through a current-limiting resistor). The other end of the primary is connected to the points within the distributor. The other end of the secondary is connected, via the distributor cap and rotor, to the spark plugs"

Last edited by a moderator:
No not yet still having problems :( Tried everything suggested in the thread but no joy. I havent got a clue what to try next:confused: Any suggestions?


Have you got Lucas points with the nut and the plastic bits?

Have you put both wires onto the loop in the points and pushed the plastic through them, then put the washer and nut on?

I have been to loads of cars where the wires were put on top of the plastic, so it earths out.

Oh S**T I'm F%$£&%! kicking myself, i only just seen your last post templ4r, and it is exactly that problem :banging: :banging: :banging:

Thanks for your help anyway


You aren't the first and definitely won't be the last to do that. It was a common problem when I worked on the RAC.

You'll remember next time though.;)

Top Bottom