• Welcome to the Land Rover UK Forums

    You are currently viewing the site as a guest and some content may not be available to you.

    Registration is quick and easy and will give you full access to the site and allow you to ask questions or make comments and join in on the conversation. If you would like to register then please Click Here

What did you do to your Defender today?

I think providing the area which has the gasket on it is smooth there shouldn’t be a reason ..seems a shame to waste it .i do believe they have gone up around £15 since I got this .
I wouldn't be surprised if it was a lot more than 15 quid.. Its frightening the cost of stuff now..
My winch came with wires but needless to say they weren't quite long enough and at the currents involved I didn't fancy adding a bit by joining and soldering it up.. I also thought the wires should be a bit beefier... Ie at least 70 square mm, so I priced two x 2.5 m lengths of 70mm and 4 ends.. £120....😳😳
 
I wouldn't be surprised if it was a lot more than 15 quid.. Its frightening the cost of stuff now..
My winch came with wires but needless to say they weren't quite long enough and at the currents involved I didn't fancy adding a bit by joining and soldering it up.. I also thought the wires should be a bit beefier... Ie at least 70 square mm, so I priced two x 2.5 m lengths of 70mm and 4 ends.. £120....😳😳
I meant £15 more now than what I gave for this one .🙄 think there around £45 now ….blimey that is expensive for wire ing ….sod all cheap now .
 
Today I dug out my old but new water pump ,I originally bought it when I had my last Defender a 300 tdi …but bought the wrong one this is for a 200 tdi which I have know ..so instead of exchanging it I got the correct one and kept it …”follow me “…
Anyway this was 6 years ago ..it’s got a bit of surface rust on the silver part and the cast has a bit of pitting .

Obviously no play as it hasn’t been used ,all good .

Do you think this is going to be ok to fit on mine .
View attachment 521536View attachment 521537
i would use it. if you fit it and it leaks you can always change it again.
 
The resistor is shown on the diagram I posted s few weeks ago.
Theres also a fair bit of information on the thread which might help you;

 
Got the chassis in primer ready for the repairs to start.
landy6.jpg
 
The resistor is shown on the diagram I posted s few weeks ago.
Theres also a fair bit of information on the thread which might help you;

That thread will also prove really useful. There was no change in the voltage when I had a jump lead running from battery to alternator.

check you have a voltage on the warning lamp wire at the alternator.
The warning light works at the dash, but I forgot to test the voltage here. It'll likely be the weekend before I get the chance to look again.
not sure what model yours is
It's a 90 from 1990 with a 300TDi from a Discovery.

In fact I'm discovering lots of WTF moments when it comes to the wiring. For example, a poorly wiring for the fuel sender when the orginal, perfectly good one was there but all taped up.
 
Back
Top Bottom